понедельник, 14 декабря 2009 г.

[comp.prog] Ruby 1.9.1-p376

7-го декабря была выпущена обновленная версия Ruby 1.9.1 – Ruby 1.9.1-p376, в которой была исправлена уязвимость с переполнением хипа и сделано еще более ста исправлений. Публикую эту новость с недельным опозданием, поскольку сразу не были доступны бинарники для Windows. Сейчас доступны, так что можно обновляться не только под Unix-ами, но и под Windows.

Исходники: http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.1-p376.tar.bz2
Бинарники под Win32: http://ftp.ruby-lang.org/pub/ruby/binaries/mswin32/ruby-1.9.1-p376-i386-mswin32.zip
Бинарники под Win64: http://ftp.ruby-lang.org/pub/ruby/binaries/mswin32/ruby-1.9.1-p376-x64-mswin64_80.zip

PS. Сам я на Ruby в последнее время практически ничего не пишу, т.к. полно работы на C++. Поэтому продолжаю пользоваться, по уже сложившейся традиции, Ruby 1.8.7. Но надо, думаю, потихоньку переползать на ветку 1.9.

Отправить комментарий