суббота, 22 октября 2011 г.

[prog] MxxRu обновился до версии 1.5.5 и поддерживает теперь Ruby 1.9.2

Нашлось время и желание таки побороть изъятие из $: текущего каталога в Ruby 1.9.2 – это сделано в MxxRu 1.5.5. Сделано все просто – в начале всех верхнеуровневых MxxRu-файлов задействована инструкция $:.unshift(‘.’). Так что теперь под Ruby 1.9.2 мои старые проекты собираются так же, как и под предыдущими версиями Ruby.

Взять новую версию можно либо со странички RubyForge, либо через команду gem install Mxx_ru (для обновления с предыдущих версий следует выполнить gem update Mxx_ru).

PS. Попутно обновил и RuCodeGen до 0.3.2 поскольку там при обработке встроенных скриптов была та же самая проблема под Ruby 1.9.2. Теперь же RuCodeGen при запуске ruby для обработки встроенного скрипта передает ruby аргумент –I. (т.е. принуждает Ruby искать rb-файлы так же и в текущем каталоге).

Отправить комментарий